View Issue Details

IDProjectCategoryView StatusLast Update
0000136WoRRaspberry Pi 4 (ARM64)public2021-02-28 15:53
ReporterMario Assigned ToMario  
PrioritynormalSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Summary0000136: Add USB 3.0 boot support workarounds
Description

USB 3.0 boot from an UASP drive fails with the INACCESSIBLE_BOOT_DEVICE BSoD.
This issue is caused by the rpiuxflt.sys filter driver, and until we find a proper fix for it, we can apply one the following workarounds:

  • replace uaspstor.sys with USBSTOR.SYS in the Windows\System32\drivers directory. (this allows the usage of all the available RAM, but transfer speeds are limited due to removed UASP support and filter driver overhead)

  • prevent the installation of the rpiuxflt.sys driver and create the following reg key: HKLM,System\CurrentControlSet\Control\Compatibility\Device\USBXHCI:ACPI!VEN_PNP&DEV_0D10,\ USBXHCI,0xB0001,0x70000000003 (this requires a 3 GB RAM limit, but transfer speeds greatly increase)

TagsNo tags attached.

Activities

Mario

Mario

2021-02-28 15:53

administrator   ~0000236

Fixed in the drivers repository: https://github.com/worproject/RPi-Windows-Drivers/releases/tag/v0.6

Issue History

Date Modified Username Field Change
2021-01-31 14:47 Mario New Issue
2021-01-31 14:47 Mario Status new => assigned
2021-01-31 14:47 Mario Assigned To => Mario
2021-02-28 15:53 Mario Status assigned => resolved
2021-02-28 15:53 Mario Resolution open => fixed
2021-02-28 15:53 Mario Note Added: 0000236
2021-02-28 15:53 Mario Target Version 2.0.2 =>