View Issue Details

IDProjectCategoryView StatusLast Update
0000024WoR[All Projects] Generalpublic2019-04-30 12:02
ReporterMarioAssigned ToMario 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status assignedResolutionopen 
Product Version 
Target Version1.1Fixed in Version 
Summary0000024: Add support for automatically fetching required binaries
Description

See comment 0000024:0000093

TagsNo tags attached.

Activities

Mario

Mario

2019-01-02 11:02

administrator   ~0000061

Last edited: 2019-01-02 11:03

View 2 revisions

The latest drivers package can be download from https://www.worproject.ml/downloads , so I don't think such functionality is really needed.
A button for downloading the UEFI directly from the application might be a good idea, but that will not happen in the 1.0 release.
I could add a direct download link on the website instead.

Mario

Mario

2019-04-30 11:40

administrator   ~0000093

Reopened.
I see there are still people that install Windows using old UEFI builds and complain about non-working USB ports.
Support for fetching the following binaries will be implemented:

  • latest drivers package compatible with WoR
  • latest UEFI binary

Speaking of Windows ISO images, UUP packages can be (legally?) downloaded from Microsoft servers, and since they don't stop us from doing it I don't think there is any issue if I implement something like the uup.rg-adguard.net service directly in WoR. I'll have to think twice before doing this, though.

Issue History

Date Modified Username Field Change
2018-10-24 16:44 Mario New Issue
2018-10-24 16:44 Mario Status new => assigned
2018-10-24 16:44 Mario Assigned To => Mario
2019-01-02 11:02 Mario Status assigned => closed
2019-01-02 11:02 Mario Resolution open => suspended
2019-01-02 11:02 Mario Note Added: 0000061
2019-01-02 11:03 Mario Note Edited: 0000061 View Revisions
2019-01-02 11:03 Mario Target Version 1.0 =>
2019-04-30 11:40 Mario Status closed => assigned
2019-04-30 11:40 Mario Note Added: 0000093
2019-04-30 11:42 Mario Target Version => 1.1
2019-04-30 11:42 Mario Summary Add in-app download buttons for drivers/UEFI firmware => Add support for automatically fetching required binaries
2019-04-30 11:42 Mario Description Updated View Revisions
2019-04-30 11:42 Mario Description Updated View Revisions
2019-04-30 11:43 Mario Description Updated View Revisions
2019-04-30 12:02 Mario Resolution suspended => open